Re: Sawfish or Xorg input bug

andrea vettorello gmail com (2008-03-03 at 2058.16 +0100):
> I can reliably "lock" Sawfish using the "cycle windows" keybind,
> simply keeping the keys pressed until the key repeat starts. As a
> result, the two or more visible windows keep switching focus. If i
> kill Sawfish and start another WM (tried with FVWM and Metacity) the
> key are still repeating, i.e. the windows keep switching focus in the
> different WM (using Alt-tab as keybind).

I have a similar issue and some others. Last months have been a bumpy
ride with Xorg. On addition of modifiers getting locked, LEDs stop
working sometimes (numlock or capslock changes the led fine at the
beginning... later the LED is always off, even if the state is changed
as shown by xkkvleds or by just checking what apps get) and the combo
to kill the server or change to another VT fail to work after some
time too (but chvt 1 and killing the Xorg binary work, so not an issue
about changing VT per se).

One day I had some time when cycling locked so I tried some things. I
discovered pressing keys worked, but always with the mod in use, so
they mostly invoked sawfish actions (few unused keys) and after
killing the wm, the keys were still stuck. Also I launched xkbwatch
from a VT and copied the display. It seems the Ctrl-Alt combo was
stuck, as well as the one used for cycling (Mod4 = Hyper = base mod
for my sf bindings), each in really weird and different way (when
pressing normally I get other layout, top and two bottom leds for a
pressed mod key, top and three bottom leds for a lock key):

o o o o o t c h
d d d d d r c f
5 4 3 2 1 l k t

_ X _ _ _ _ _ _  base
_ _ _ _ _ _ _ _  latched
_ _ _ _ _ _ _ _  locked
_ _ _ _ X X _ _  effective
_ X _ _ _ _ _ _  compat

Column labels based in testing and xmodmap.
Row labels from (maybe upside down?):

So now I tend to check LEDs or do VT switching at random, hoping to
catch the culprit (back from DPMS? some app was launched recently?
xvideo ext in use? etc). Sometimes, when coming back from another VT,
some apps are kept in stopped state and I have to kill -CONT them or
the windows are just flat colour. But currently I am unable to predict
100% when keys or leds will stop working.

As stop gap for locking, I disabled repeat for Tab key and decided to
not overload the X11 system and at the same time press mod keys, as
the mod lock seems to be related to high server "(un)mapping" activity
(cycling windows, launching many new windows in a short time, cycling
over workspaces...).

Versions are same than yours, but worked fine with 2.6.24 kernel until
last Xorg update. Maybe sawfish triggers something in the radeon
driver, or the xorg core or kbd driver (or I had luck the week I had
new kernel with "old" X). I know it did not happen with radeon driver
6.6.x, xorg 1.3 and kernel .23 or older. The time I used radeon 6.7.x
(sorry, speaking from memory) I had some full kbd locks (mouse moved,
apps updated, but sshing required to kill the server) so I reverted to

Additionally, official Flash plugin r115 worked smoothly with old
radeon driver, but with new I had to revert to r48 version or get 80%
usage in the Xorg process, 15% in the browser (and 5% in others) and
drop frames with XAA accel arch, or poor window refresh and GTK
glitches but nice frame rates with EXA (yep, slowdown changed from the
flash anim to the rest of the browser). Now when time pases and DPMS
is not triggered, I wonder if some vibration moved the mouse or it is
another flacky thing. I am starting to see bugs everywhere. :]

Stuck keys do not seem to be sawfish or radeon only. You can find
people having issues with different wm (wmii, compiz, fluxbox), apps
(vmware, games) and drivers (nvidia, nv). Examples:


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]