Re: rep-gtk build issue

On Wed, Sep 12, 2007 at 03:41:30PM +1000, Allan Duncan wrote:
> Stephen Nelson-Smith wrote:
>> On 9/11/07, Stephen Nelson-Smith <sanelson gmail com> wrote:
>>> Hello,
>>> I'm building RPMs for Sawfish, and its dependencies for the CentOS 
>>> project.
>>> I've built librep (from 0.17 sources), imlib (from 1.9.15) and am
>>> currently finding rep-gtk won't build.
>> OK - patch to fixed this rolled into the rep-gtk rpm, so we're good to go.
>> Am now running into an issue where the sawfish configure script is
>> testing for X11, and reporting no.

The checks for X and such are in lines 89-144. It looks for
 X11/SM/SMlib.h, X11/extensions/Xdbe.h, X11/extensions/Xinerama.h,
and, with pkg-config, for 
  xft >= 1.0 (X11/Xft/Xft.h)

Debian satisfies build dependencies with the following packages:
 libxinerama-dev, libesd0-dev, rep-gtk (>= 0.18-9),
 libgmp3-dev (>= 4.1.4-8), libgtk2.0-dev (>= 2.0.6),
 libxrender-dev, libxext-dev, libxt-dev, librep-dev (>= 0.17-12)

As well as the following, which provide tools, not headers or such:
 gettext (>= 0.10.37-1), texinfo, automake1.10

Hope this helps.

Attachment: signature.asc
Description: Digital signature

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]