Re: [Rhythmbox-devel] cannot play MP3's in Fedora 25

On Mon, Feb 06, 2017 at 02:27:07AM +0000, Bob Nolty wrote:
Hi all --

I've been using Rhythmbox for many years, thanks!  But I recently upgraded my desktop to Fedora 25 and I 
haven't got Rhythmbpox to play any MP3s.  I first tried installing gstreamer1-plugins-* from RPMFusion; and 
when that didn't work I uninstalled gstreamer1-plugins-ugly and installed gstreamer1-plugin-mpg123 and 
mpg123-libs from the default Fedora repositories, as suggested by this page:
In both cases, whenever I click on an MP3 song in rhythmbox, I get a notification that 'an application is 
requesting an additional codec', and a button to open the 'Software' application.  The Software application 
crashes before doing anything, but that's not your problem :-/

I can play MP3s with the mpg123 command line program and with VLC.  Totem behaves essentially the same as 

Any ideas?  Or is there a better place for me to ask?

Sorry it took so long for me to reply - I've been taking a bit of a break from
working on rhythmbox for various reasons that seem to be coming to an end now.

mp3 playback works fine for me on fedora 25 using mad (from rpmfusion's gstreamer1-plugins-ugly)
and mpegaudioparse (from gstreamer1-plugins-good).  I've just tried mpg123 and that seems to
work properly too.

Output from 'gst-launch-1.0 -m filesrc location=file.mp3 ! decodebin ! fakesink' would probably help.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]