[Rhythmbox-devel] Problem with 2.99.1 installation


I am trying to install the latest version of Rhythmbox 2.99.1 on Ubuntu 13.04 over the top of version 2.98 and when I try to configure the package downloaded from the GNOME ftp site, I get the following dependency errors:

checking for RHYTHMBOX... no
configure: error: Package requirements (          gobject-introspection-1.0 >= 0.10.0           gtk+-3.0 >= 3.6.0                      x11             
gdk-pixbuf-2.0 >= 2.18.0              glib-2.0 >= 2.32.0                 
gio-2.0 >= 2.32.0                      gio-unix-2.0 >= 2.32.0        
libsoup-2.4 >= 2.26.0                  libsoup-gnome-2.4 >= 2.26.0             
libpeas-1.0 >= 0.7.3                  libpeas-gtk-1.0 >= 0.7.3             
libxml-2.0 >= 2.7.8                  tdb >= 1.2.6                    
 json-glib-1.0) were not met:

No package 'libsoup-gnome-2.4' found
No package 'libpeas-1.0' found
No package 'libpeas-gtk-1.0' found
No package 'tdb' found
No package 'json-glib-1.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables RHYTHMBOX_CFLAGS
and RHYTHMBOX_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

I understand that this error can be solved by downloading the necessary packages, however all but  sudo apt-get install libsoup2.4-dev failed to locate the required packages.

Does the latest 'stable' release of Rhythmbox rely on unreleased packages or am I approaching this from the wrong angle.

A little advice would be helpful.
All the best,

Simon Thomson

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]