Re: [Rhythmbox-devel] errors running media-sync-branch

I updated my sources from the media-sync-branch and rebuilt.  Now when I press Sync I no longer see the gtk_action_set_sensitive assertion, but unfortunately it still does not seem to be syncing: nothing happens.

I did also see some of these messages while my iPod was connected:

** (rhythmbox:5211): WARNING **: Unknown action type 33554433
** (rhythmbox:5211): CRITICAL **: itdb_splr_validate: assertion `at != ITDB_SPLAT_UNKNOWN' failed

I would love to see syncing working and merged into trunk in time for GNOME 2.30 this spring.  I have a feeling there's a bit work to be done, however.  Even if the missing action warnings are benign, we should fix them anyway: a well-behaved GNOME program should not normally be printing warnings.

Jonathan, in a message in December you said you weren't completely happy with the sync settings dialog.  I personally think it's usable enough for now - if syncing worked reliably, I think users would much rather have this capability including this dialog than not have it at all.

Jonathan, are you able to sync reliabily to an iPod using the current code base?

I hope to be able to help with getting this working to the point where we can merge into trunk.  I'll delve into the syncing code and see if I can figure out what's wrong on my system.


Jonathan Matthew wrote:
On Thu, Jan 21, 2010 at 6:51 AM, Adam Dingle <adam yorba org> wrote:
I'm very interested in the effort to make Rhythmbox sync with media players,
so I thought I'd try out the media-sync-branch code.  I fetched the branch,
built and installed.

Thanks for trying it out. Hopefully we can get it working for you..

When I run this Rhythmbox, I see errors like these:

(lt-rhythmbox:15527): Gtk-WARNING **: iPodSrcPopupSync: missing action

I think I know why this is happening. It should be harmless.

** (lt-rhythmbox:15527): CRITICAL **: atk_object_set_name: assertion `name
!= NULL' failed

This one's harmless, I think.. not sure what causes it though.

When I try to sync, nothing happens and I see errors like these:

(lt-rhythmbox:15527): Gtk-CRITICAL **: gtk_action_set_sensitive: assertion
`GTK_IS_ACTION (action)' failed

This should be fixed now. I don't think it was the cause of the
greater problem, though.

Any idea as to what's wrong?  I could debug a bit, but I thought I'd ask
here first.  I'm running Ubuntu 9.10 (Karmic).

I haven't touched this code for a while, but I'm pretty sure it worked
(in some sense) when I created the branch..
Output from 'rhythmbox -D media' might have some useful information.
rhythmbox-devel mailing list
rhythmbox-devel gnome org


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]