Re: [Rhythmbox-devel] strange compile issue

Thanks, that allowed me to catch it.  I attached the backtrace.  Looks like the error may not have come out of rhythmbox.  I am going to try recompiling all of the libraries referenced in that dump and I'll post back.

GNU gdb 6.3
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i686-pc-linux-gnu"...Using host libthread_db library "/lib/".

(gdb) run
Starting program: /usr/bin/rhythmbox
[Thread debugging using libthread_db enabled]
[New Thread -1230027088 (LWP 29445)]
[New Thread -1243620432 (LWP 29448)]
[New Thread -1252013136 (LWP 29449)]
[New Thread -1252688976 (LWP 29450)]
[Thread -1252688976 (LWP 29450) exited]
[New Thread -1252688976 (LWP 29451)]
[Thread -1252688976 (LWP 29451) exited]
[New Thread -1252688976 (LWP 29452)]
[New Thread -1264583760 (LWP 29453)]
[Thread -1252688976 (LWP 29452) exited]
[Thread -1264583760 (LWP 29453) exited]
[New Thread -1252688976 (LWP 29454)]
[Thread -1252688976 (LWP 29454) exited]
[New Thread -1252688976 (LWP 29455)]
[New Thread -1264583760 (LWP 29456)]
[New Thread -1272976464 (LWP 29457)]
[Thread -1264583760 (LWP 29456) exited]
[Thread -1272976464 (LWP 29457) exited]
[Thread -1252688976 (LWP 29455) exited]
[New Thread -1264583760 (LWP 29458)]
[Thread -1264583760 (LWP 29458) exited]

** (rhythmbox:29445): WARNING **: nautilus_burn_drive_free is deprecated please use nautilus_burn_drive_unref() instead

** (rhythmbox:29445): WARNING **: nautilus_burn_drive_free is deprecated please use nautilus_burn_drive_unref() instead
[New Thread -1264583760 (LWP 29459)]
[Thread -1264583760 (LWP 29459) exited]

Program received signal SIGBUS, Bus error.
[Switching to Thread -1243620432 (LWP 29448)]
0xb6fa7bac in memcpy () from /lib/
(gdb) bt
#0  0xb6fa7bac in memcpy () from /lib/
#1  0xb6b60eb8 in g_memdup () from /usr/X11R6/lib/
#2  0xb72b0baa in gst_buffer_default_copy ()
   from /usr/X11R6/lib/
#3  0xb72b5c97 in gst_data_copy () from /usr/X11R6/lib/
#4  0xb6dab61a in g_gstring_get_type () from /usr/X11R6/lib/
#5  0xb6dc380d in g_signal_emit_valist ()
   from /usr/X11R6/lib/
#6  0xb6dc3c41 in g_signal_emit () from /usr/X11R6/lib/
#7  0xb55a02e6 in gst_buffer_store_add_buffer ()
   from /usr/lib/gstreamer-0.8/
#8  0xb55b41f1 in gst_type_find_element_get_type ()
   from /usr/lib/gstreamer-0.8/
#9  0xb72d427f in gst_pad_call_chain_function ()
   from /usr/X11R6/lib/
#10 0xb72d148e in gst_pad_push () from /usr/X11R6/lib/
#11 0xb4d46011 in gst_mad_tag_list_to_id3_tag ()
   from /usr/lib/gstreamer-0.8/
#12 0x0811bdd8 in ?? ()
#13 0x0038238c in ?? ()
#14 0x00000000 in ?? ()
#15 0xb6dce6b2 in g_type_check_instance_cast ()
   from /usr/X11R6/lib/
Previous frame inner to this frame (corrupt stack?)

On 11/29/05, James Livingston <jrl ids org au> wrote:
On Tue, 2005-11-29 at 11:37 -0600, James Cotton wrote:
> I noticed that when I updated the CVS yesterday and that fixed the
> compile problem.  I'm getting a seg fault I've been getting for a few
> days still.  I tried to get a backtrace but what happens is I run
> gdb /usr/bin/rhythmbox and type run, then the cont commands, and it
> just hangs like that until I kill gdb.  When I run RB w/o gdb it at
> least comes up, starts to load the library, continues for a bit then
> crashes out.  I attached the gdb run in the bottom in case I'm doing
> something silly.  Also I attached the last 10 lines of the -debug
> output in case it is revealing, but I dont' think it is.
> Program received signal SIG33, Real-time event 33.
> [Switching to Thread -1251656784 (LWP 9402)]
> 0xffffe410 in __kernel_vsyscall ()
> (gdb) cont
> Continuing.

You need to add "handle SIG33 pass nostop noprint" to your ~/.gdbinit.
That will stop the real-time events from stopping gdb.


James "Doc" Livingston
"Every time I look at my speedometer, I get lost!"
    Heisenberg's Automotive Lament

Version: GnuPG v1.4.2 (GNU/Linux)


rhythmbox-devel mailing list
rhythmbox-devel gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]