Re: [Rhythmbox-devel] strange compile issue

On Tue, 2005-11-29 at 11:37 -0600, James Cotton wrote:
> I noticed that when I updated the CVS yesterday and that fixed the
> compile problem.  I'm getting a seg fault I've been getting for a few
> days still.  I tried to get a backtrace but what happens is I run
> gdb /usr/bin/rhythmbox and type run, then the cont commands, and it
> just hangs like that until I kill gdb.  When I run RB w/o gdb it at
> least comes up, starts to load the library, continues for a bit then
> crashes out.  I attached the gdb run in the bottom in case I'm doing
> something silly.  Also I attached the last 10 lines of the -debug
> output in case it is revealing, but I dont' think it is.
> Program received signal SIG33, Real-time event 33.
> [Switching to Thread -1251656784 (LWP 9402)]
> 0xffffe410 in __kernel_vsyscall ()
> (gdb) cont
> Continuing.

You need to add "handle SIG33 pass nostop noprint" to your ~/.gdbinit.
That will stop the real-time events from stopping gdb.


James "Doc" Livingston
"Every time I look at my speedometer, I get lost!"
    Heisenberg's Automotive Lament

Attachment: signature.asc
Description: This is a digitally signed message part

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]