Re: [Rhythmbox-devel] Breakage on merge branch (patch-57)

On Thu, 2005-05-05 at 19:44 +0200, Oliver Lemke wrote:
> Can you verify that a completely new checkout of the merge branch still
> contains the void param? I just tried on a remote machine updating an
> existing copy and a checking out a new copy directly from my public
> archive and in both cases rb_sourcelist_new expects RBShell as a
> parameter. No idea what is going wrong here.

I grabbed a new copy of your merge branch, and it still didn't work. I
then tried the following:

1) Get a copy of the merge branch, and reverse patch-57 with `the replay
--reverse olemke core-dump info--2005/rhythmbox--merge--0.9--patch-57`
so that I have a copy without patch-27 of Jonathan's bugs branch

2) Download patch-27 manually and check the contents of the .patch files
to ensure that they contains the changes that are supposed to. They do

3) Run `tla replay
jonathan kaolin hn org--2005/rhythmbox--bugs--0.9--patch-25` to apply
the contents of the patch

For some reason the resulting source tree contains *some* of the changes
in the patch, but not all of them. Arch is applying the patch
incorrectly, but not giving me any warnings or errors. The same problem
occurs if I update from patch-56 of the merge branch to patch-57; Arch
does not apply the patch correctly.


James "Doc" Livingston 
Finding a needle in a haystack is a lot easier if you burn down the
haystack and scan the ashes with a metal detector. 
    -- the Silicon Valley Tarot (another one nicked from David Rush)

Attachment: signature.asc
Description: This is a digitally signed message part

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]