Re: [Rhythmbox-devel] Assertions

On Thu, 2005-04-07 at 11:59 +1000, Jonathan Matthew wrote:
> It looks like you might be trying to run the rhythmbox binary from the
> source tree.  This won't work unless you add --enable-uninstalled-build
> to the (or configure) command line.
Well, son-of-a-gun, that worked! Thanks!
Previously I would try to execute shell/rhythmbox and failing that I did
an actual install into /usr/local/bin and it still gave the error. Now
I'm just running from my build directory and everything works.
One more issue:
After running shell/rhythmbox, when I close it and try to open again I
get a segmentation fault (nothing written to stderr though).
But now, if I run my old rhythmbox (version 0.8), close it and then
rerun shell/rhythmbox, it works again (except, the playlist window now
has a new "Queue" playlist item which I can kind of understand as
rhythmbox 0.8 treats the queue as a normal playlist).

> generally spits out some weird-looking warnings, but as long
> as it generates and runs the configure script, it should be OK.
> What weird macro errors is it giving you?
Something about AM_LIBTOOL (and various others) being underquoted.
I think my problem might be that I've got several versions of aclocal,
autoconf and automake installed.

In any case, thanks for the help.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]