Re: [Rhythmbox-devel] autopackage

Dnia 31-10-2004, nie o godzinie 01:12 +0200, Carlos Perelló Marín
> > Does rhythmbox have any plans for using autopackage once it reaches
> > 1.0 status.  I use Mandrake 10.1 and have many dependency problems
> > that using would solve.
> I don't see what gives you autopackage that .rpm or .deb does not solves
> at the moment. It sounds like the same thing... or perhaps worst, the
> package dependencies are not bad, they are there so you can be sure that
> an application will work always, if you try to remove a needed library,
> the system will warn you that there are installed an application that
> needs that library.

Umm, are you sure you're talking about autopackage here? Autpackage will
use native package manager if available, and fallback only for deps not
found on target platform.

> I can only imagine your problem if you are trying to install a binary
> from Redhat into Mandrake or things like that. If that's the case...
> sorry, but I don't see autopackage as the solution. 

Not really, it happens every time your target distro lacks particular
dependency packaged.

> I would be good to
> see how autopackage handles the installation of a GNOME 2.8 application
> in a GNOME <= 2.6 environment forgetting the dependencies...

At this stage of development, I think it's supposed to behave good in
this situation, although that would probably mean installing whole 2.8


"Tautologizm to coś tautologicznego"
   Maciej Katafiasz <mnews2 wp pl>

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]