[Rhythmbox-devel] trouble installing Rhythmbox 0.8 in Red Hat 9

Hi.. I somehow got Rhythmbox working a week or two ago, but had to
reinstall Linux (Red Hat 9). I tried following the process documented
(which worked a couple weeks ago) but can't get it to work now with
0.8.  I don't remember what version of Rhythmbox I installed before, but
I'm guessing it was 0.7.x.  Anyway, here's my problems:

1. I install the Fedora RPM for Gstreamer with no problems. But when I
configure Rhythmbox, it says I'm missing gstreamer-libs-0.8.  I ran a
find from root and this file does not exist on my system.  I have
gstreamer-control-0.8.pc and gstreamer-0.8.pc but not
gstreamer-libs-0.8.  When I installed previously, I was able to find the
missing file and copy it to the correct directory (pkgconfig) and it

2. So I tried configuring with xine support, which worked except I
couldn't play MP3s.  Then I remembered that I needed libid3tag, so I
installed libid3tag.  Now I can configure and make rhythmbox with no
errors (that I noticed), but when I launch rhythmbox, I get this
        rhythmbox: error while loading shared libraries: libid3tag.so.0:
        cannot open shared object file: No such file or directory
I can find the file (/usr/local/lib/libid3tag.so.0) and I tried copying
it to /usr/local/lib/pkgconfig, but that didn't work.  

Any suggestions?  Rhythmbox is by far my favorite music player/organizer
I've used so far.. I'd really like to get it working.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]