[Fwd: Re: Glade3: Libgnome(ui) and bonobo]

So to keep GNOME3 cleanup progress tracked I'm forwarding this.
Note that all bonobo/libgnome(ui) hits are in /plugins/gnome and


-------- Forwarded Message --------
> Von: Tristan Van Berkom
> An: Andre Klapper
> Betreff: Re: Glade3: Libgnome(ui) and bonobo
> Datum: Wed, 24 Jun 2009 12:09:24 -0400
> On Wed, Jun 24, 2009 at 9:36 AM, Andre Klapper<ak-47 gmx net> wrote:
> > Hi Tristan,
> >
> > before I file useless bugs against Glade3, which of the following
> > includes are needed by Glade3 for legacy support to create deprecated
> > widgets and what is really stuff that should be removed for GNOME 3?
> Hi,
>   everything in the plugins/gnome directory is needed for support of
> deprecated libgnomeui/bonoboui widgets (and ofcourse the line in
> confgure.ac to detect its presence).
> I honestly havent thought hard about what Im going to do for
> deprecated GTK+ widgets, that is probably going to depend on
> how backwards compatability is offered.
> If theres a support lib offered to cover deprecated apis that
> you can link along with GTK+ 3.0, then I will probably try to
> depend on GTK+ 3.0 and offer the deprecated widgets in
> a separate plugin, or possibly I will try to just virtualize all
> the remaining deprecated widgets.
> Cheers,
>           -Tristan
 mailto:ak-47 gmx net | failed
 http://www.iomc.de/  | http://blogs.gnome.org/aklapper

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]