Re: ERROR:root:Requiring namespace 'Gtk' version '2.0', but '3.0' is already loaded

On Tue, Nov 16, 2010 at 11:13 AM, John Palmieri <johnp redhat com> wrote:
> from gi.repository import Gtk
> Gtk.require_version('2.0')

Thanks J5, you're amazing! I'll try this as soon as I get home tonight.

Just a quick thought though -- requiring version 2.0 seems kinda like
a stopgap solution. I want to be future-proofing my application,
developing for the latest versions, not ignoring 3.0 with my head
buried in the sand.

Am I just basically waiting for the Champlain people to catch up with
gtk3 development, or is there something I can do to make 3.0 work?

Thanks again!


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]