[Planner Dev] Re: [Fink-devel] Success! -> Planner on Darwin/FreeBSD/OSX

On Mac OS X /usr/bin/libtool is not GNU libtool, it is apple's shared library helper, which was inherited from NeXT, you can download and build it if you want, it is part of the cctools project. If you install GNU libtool in /usr you will break your toolchain and will not be able to build shared libraries.

I suggest instead that you use fink to install automake1.9 (1,9,2) autoconf2.5 (2.5.9) and libtool14 (GNU libtool-1.5.10) and then run autogen.sh, do not mess with apple installed stuff in /usr.

Peter O'Gorman - http://www.pogma.com

Thanks Peter,

Yes, I tried that and autogen.sh still didn't work, so I backed up apple's libtool, installed gnu libtool, ran autogen.sh which worked. Then before make I copied the backed up libtool back to /usr/bin/libtool. Then everything worked fine. Se la vi :)

But absolutely right, let Apple's stuff be Apple;s.


Alessandra & Assoc. Intl.
Dallas * Ft. Worth, Texas  U.S.A.
(214) 335-0278

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]