Re: [Planner Dev] [PATCH]: cleanups

On tor, 2004-05-20 at 18:21 +0200, Tomasz Kłoczko wrote:

> Forcing using automake/aclocal 1.7 probably in this case means in this 
> case "force using correct version" but realy wil mean "force using Linconl 
> correct version"  :o)
> If Lincon will remove automake 1.7 and will install (correctly) some other 
> (for example last) version of automake and still wil not remove buggy 
> another version it will mean we will change ? :_)

There were several people telling me that planner didn't build after the
change, and I care more about that than a "nice" autogen script. The
only thing we do is specify the DEFAULT version used if the one building
doesn't specify another version.

=> We make life easier for testers and ourselves, and if someone wants
to build with say 1.6 or 1.8, they can set the environment variable
before building.

This whole issue is completely unrelated to who to make the build use or
require a specific version of automake, this is just a simple way to
specify the default, so people can built the thing.

If we fix the scripts to check for 1.7+ and use 1.7+ then we can remove
the default version, we won't remove it before that.


Imendio HB,

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]