Re: getting the initial setup working

Yeah, no problem... I was just trying to see how well your
instructions on the wiki work.
I've pushed an easy-fixes branch with some more trivial things. I came
across a few more issues that should perhaps be mentioned on the wiki:

- I had to add the minimal content to /ostree/var/passwd and
/ostree/var/groups and edit the fstab in the image to get my home
directory mounted, before I could successfully log in.

The desktop I was greeted with was sadly fallback mode, with missing
icons and a terrible monospace font...but I was pretty happy to get
this far.

After this, I tried to see if I could get the ostbuild stuff working
to build the missing icons. Didn't quite get that far.

ostbuild tree-to-bin wouldn't work until I figured out that I had to
pass --tree=/ostree/gnomeos-3.4-i686-devel - the gnomeos instructions
didn't mention the /ostree/current symlink, so I didn' t have one at
this point.

Next, bin-to-src would't work, because there are no components in my
repo. I looked around and discovered the pull-components command. I
had to fix it to make it work, see the easy-fixes branch. After
pulling all the components, bin-to-src did work.

Then, I ran into problems with ostbuild build-components, but it had
gotten too late to investigate those further...

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]