Re: [orca-list] Problems with KDE Plasma terminal emulator "Konsole"


ok let me check all this at home.

a small funny side information for you as i read "Accerciser":
do you know "libqaccessibilityclient"?

the name is rather strange because its not only a lib but also some nice tools for debug accessibility stuff like Accerciser, but i find it more responsive and less buggy sometimes. you can take a look at if you are intrested in having a QT A11y introspector :).

overall plasma seems to be very accessible but some importaint stuff is missing

- default main menu (the alternatives are working lol)
- the Wifi networks are not keyboard navigateable
- performance and stability seems to be an issue too

i will work on this if i find free time. but free time is currently rare lol.

cheers chrys

Zitat von Joanmarie Diggs <jdiggs igalia com>:

Hey again.

We were getting focus and caret-moved events for something with role
accelerator-label. That seemed bogus, so I'm now filtering those out in
Orca master.

Having solved that problem, I went looking for the accessible object
with role terminal in Accerciser, but couldn't find it in the
accessibility tree. Weird. I also couldn't find the accelerator-label
object in Accerciser. Then I did some local debugging. The object with
role accelerator label happens to have the same text as what I see
displayed in the terminal. So here are my guesses:

1. Somehow the terminal is getting role accelerator label. That needs to
   be fixed. Aside from it being a bogus role for a terminal widget,
   Orca uses the terminal role to identify when the terminal script
   should be used. I might be wrong, but I think this should be an
   easy fix.

2. Assuming you, too, don't see the terminal widget in the accessibility
   tree, it would be good to figure out why that is and fix it. Whether
   or not doing so will have a screamingly-obvious impact on Orca is
   hard to say. But Orca does make some decisions about what to present,
   and also obtains the stuff to present, by looking in the
   accessibility tree. If that tree is broken, Orca might do the wrong

Lastly, I found an ancient hack in Orca for Qt in which we just trust
that if we get a state-changed:focused event with detail1=1, it's a
valid focus claim. This was (and perhaps still is?) needed because
either the focused state and/or the focusable state were missing from
the state set. I haven't removed that hack, but I have now added some
extra debugging. We don't want missing states, because there can be
other places Orca uses those states to decide what to present. Now
something you could do is enable full debugging in Orca, use some QT
apps, then look in the resulting debug.out. Search for "QT: WARNING". If
you find it, please figure out why the state is missing and fix it. :)

Please let me know if you have any questions. And thanks for all your
work in this area!


On 4/8/19 9:12 AM, Joanmarie Diggs wrote:
Hey Chrys.

Sure thing. I'm using KDE now myself. :)


On 4/7/19 6:03 PM, chrys wrote:
Howdy Joanie,

i currently do some new testing session for KDE Plasma.

First of all, Thanks for the KWin script. i just test it,, the window
switcher now works now very awsome with orca master :). Thanks!

I just play around with "Konsole" its the KDE Plasma Terminal emulator.
and i figured, it has an A11y implementation! But it seems some kind of
broken as orca doesn't announce incoming text or word echo like it does
in gnome-terminal. But  i also figured that the text is available in
review. Maybe could you take a look what broken that i can see what i
can do to fix it?

cheers chrys

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]