[orca-list] Installing Orca fails on Debian Lenny

Hello at all,

I'am new at this list and so I want to introduce myself shortly: My name
is Eric and I'am from Germany. A half year ago I decided to start with a
Debian based server. This was my first contact with Linux. Since then
I've learned a lot but I only controlled the server remotely
via SSH so I didn't need a server site screen reader. Now I've decided
to use Debian also with my laptop.  Therefore I tried to install Orca
but this fails.
I use Debian Lenny and during the installation process I've chosen the
packages "desktop", "laptop" and "standard". I installed it with my Baum
Supervario 40 USB braille device and Brltty. Then the installation
process was finished, I configured my sound card with ALSA support
(alsaconf). Then I installed Speakup to get speech output for the
console (packages: "speakup-sources", "espeakup" and "espeak"). Next I
got Orca with the command "apt-get install gnome-orca".
But when I want to start Orca with the command "orca -t" I always get
this error:
GtkWarning: could not open display
  warnings.warn(str(e), _gtk.Warning)
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/var/lib/python-support/python2.5/orca/orca.py", line 54, in
    import pyatspi
  File "/usr/lib/python2.5/site-packages/pyatspi/__init__.py", line 44,
in <module>
    reg = bonobo.activation.activate_from_id(REGISTRY_IID, 0, 0)

I don't know what this should tell me except that I have a problem with
the gnome accessibility registry. Could someone help me solving this

Thank you in advance

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]