Re: [orca-list] Orca Find

Hey Storm.

with it. Is it broken?

It has it's occasional quirks, but it's not broken to my knowledge.

 I first was checking in a file for 3 # characters.

I just tried this and it worked.

 I could have easily done it with the find dialog built in to Gedit,
but I decided to use Orca's version instead. It didn't move the cursor
to the new location,

It's not supposed to move the cursor. If everyone thinks it should, then
that is an RFE. But Orca Find is a flat review feature. It attempts to
locate the string you provide by looking at:

1. what's on screen
2. in the focused/active window

So if your '###' were not visible, Orca Find should not find it. And if
there were a visible toolbar button which contained '###' Orca Find
should find it. And if the '###' is visible in the text widget in gedit,
and if gedit was focused immediately before you launched find, Orca Find
should find it. And if it fails to do so, then that's a bug.

 and after the second attempt it said the string was not found.

Are you sure the ### was visible at the time and that the gedit window
was the active window?

 So, I created a file with:
This is some text
this is more text
this is even more text
and did a search for the word text.

I did this and it worked as expected.

 It said the word some, not text,

That would be a bug. If you can make it happen, please file it. Also
please capture a screen shot if possible.

 but still did not move  the location of the cursor

Because it's a flat review feature, it would not move the cursor, but if
you continued to use flat review you should (hopefully) discover that
the flat review context position was the match.

So, am I missing some critical concept, or should I be filing a bug?

Possibly both. <smile> Having read the above, please let me know what
you discover.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]