Re: [orca-list] Eclipse 3.6RC3 seems to be very unstable with orca

I don't know whether it comes from the same thing, I don't need to set all that on my debian system, it also happens outside eclipse (eg. if I run SWT snippet #212 using SWT 3.6RC4).

I will have a go on my ArchLinux system for reproducing what you describe (there is no point on the debian system as I couldn't prove whether it was your changes causing the crash or if it was just one which I am currently observing).

Michael Whapples
On 23/06/10 14:31, Josà Vilmar EstÃcio de Souza wrote:
I included a description on how to I can reproduce the bug.
Can you try?
Thanks again.
On 06/23/2010 09:14 AM, Michael Whapples wrote:
The bug in the eclipse bugzilla is 315906.

Here is a few summary notes:
* I seem to be able to cause it in any SWT StyledText control using SWT
* I haven't been able to reproduce the bug on ArchLinux (but may be its
still there but very rare).
* I get is when using IBM JDK as well as the Sun one.
* Sometimes I spot warnings which I think relate to GTK or glib (can't
remember them exactly, features g_slice I think (I am quite sure I
posted that warning message in the bug report).

I haven't got round to trying to recompile SWT, I doubt it would help
really anyway but might be worth trying.

Michael Whapples
On -10/01/37 20:59, Josà Vilmar EstÃcio de Souza wrote:
Hi Michael.
Any news about this problem?
Today I received three crashes, even using IBM JDK.
you told that you filed a bug in eclipse.
Can you tell me the number of the bugg?

On 06/06/2010 01:09 PM, jose vilmar estacio de souza wrote:

I didn't find a .deb to IBM jvm.
I found a .rpm and I used alien to convert to .deb.
I do not have the url to java VM here but I found looking in google.

On 06/06/2010 01:03 PM, Michael Whapples wrote:

OK, understood. I have filed a bug with eclipse on this saying that I
have accessibility enabled.

Out of interest as you say the IBM JVM doesn't have the exiting bug,
could you remind me what the IBM JVM is called and do you know if
ubuntu has a package for it (thinks, if ubuntu has a package for it
then Debian has a reasonable chance of having a package). Do you get
any negatives from having to run the IBM JVM?

Michael Whapples
On 06/06/2010 04:56 PM, jose vilmar estacio de souza wrote:

What I said is that I didn't think that this was caused by orca.
However I think that this is related to accessibility.
I suspect that if you could get accessibility disabled in your
system, the problem would disappear.
There is for example an old problem with eclipse in ubuntu in which
eclipse does not exit when I try to quit. The problem only happens if
accessibility is enabled. This is why I use java VM from IBM. The
problem does not happen with this VM.

On 06/06/2010 11:52 AM, Michael Whapples wrote:

I just tried the OpenJDK incase there is something specific in the
SunJDK which causes this but I still get the crash.

I will go and file a bug with eclipse (any tips on how to do it), I
just thought due to the high number of crashes I get it couldn't
normally get through like this and so may be it was something due to
having accessibility/orca running. From what you say accessibility
isn't the cause.

Michael Whapples
On 06/06/2010 01:19 PM, jose vilmar estacio de souza wrote:

I don't think that this can be cause by orca.
I am not running java from sun, insted I am running java from ibm
and my distro is ubuntu 10.04.
Perhaps this can make some difference.
I think that you should open a bug in eclipse bugzilla.

On 06/06/2010 07:15 AM, Michael Whapples wrote:

As an example of how unreliable this seems, in the last five
minutes I have just had at least three crashes. I managed to catch
what was output to the console while running the SWT snippet(212).
I attach the logfile the following refers to.
# A fatal error has been detected by the Java Runtime Environment:
#  SIGSEGV (0xb) at pc=0xb398be16, pid=5078, tid=3066833776
# JRE version: 6.0_20-b02
# Java VM: Java HotSpot(TM) Client VM (16.3-b01 mixed mode,
sharing linux-x86 )
# Problematic frame:
# C  []
# An error report file with more information is saved as:
# /home/mike/workspace/SWTBrowser/hs_err_pid5078.log
# If you would like to submit a bug report, please visit:
# The crash happened outside the Java Virtual Machine in native
# See problematic frame for where to report the bug.

I am using debian unstable, but eclipse 3.6RC3 is the tarball from
the eclipse website. Orca is from GIT, pulled last night (a matter
of hours old).

Any more thoughts?

BTW: Accessibility in general seems to be quite improved in
3.6RC3, its just such a shame it crashes as often as it does for
me, rendering it useless.

Michael Whapples
On 06/06/2010 02:03 AM, jose vilmar estacio de souza wrote:

Hi Michael
I am using eclipse 3.6 rc3 on my day job without big problems.
What distro are you using?
What version of orca?
What java VM?

In my opinion this is the more stable version of Eclipse that
I've used with the orca.


On 06/05/2010 09:47 PM, Michael Whapples wrote:

I have noticed that when using eclipse 3.6RC3 (other SWT
applications using SWT3.6RC4 seem to also exhibit this) seem to
be very unstable while running orca (I don't know whether it is
due to orca/accessibility running, but I doubt such
unreliability could be accepted by the large eclipse user base).

I haven't noticed a exact way of causing eclipse to crash, but
as it happens so frequently I will give what actions seem to be
able to cause the crash. Open eclipse and choose a source file
and enter the source code editor. Now just cursor around
(generaly less than a minute), for me it will crash very soon,
but I can't give any specific movement to do to cause one.

I also notice it for some of the SWT Snippets when using SWT
3.6RC4 (eg. Snippet212 "embedding images in StyledText" will
also crash when cursoring around its StyledText control while
having orca running).

Is this an orca issue, are we doing something to crash eclipse
or is it something in SWT?

Does anyone else notice this? I never had this sort of issue
with earlier versions of eclipse (in fact I am unsure whether I
have ever had an eclipse crash until I tried eclipse 3.6RC3).

Michael Whapples
orca-list mailing list
orca-list gnome org
Visit for more information on Orca.
The manual is at

The FAQ is at
Netiquette Guidelines are at

Log bugs and feature requests at
Find out how to help at

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]