Re: [orca-list] Orca dies after the initial "welcome to orca" and test-speech works

Am still having the same issue: orca dies just after the initial message. It also dies as soon as I try and enter the preferences UI from the main window. This means I have no ~/.orca directory, so I can't turn on debugging. I tried creating ~/.orca by hand, rebooting, and still the same issue and I still have nothing under ~/.orca so scan't get debugging:

I've just finished rebuilding orca, atk, gail, and atspi for the millionth time all from svn.

Where else can I look for a problem?

-- Rich

----- Original Message ----- From: "Willie Walker" <William Walker Sun COM>
To: "Rich Caloggero" <rjc MIT EDU>
Cc: <orca-list gnome org>
Sent: Wednesday, May 28, 2008 4:33 PM
Subject: Re: [orca-list] Orca dies after the initial "welcome to orca" and test-speech works

Hi Rich:

atk/gail/at-spi are all used by the core stuff on the machine, so you need to make sure the core stuff can find it. This typically means explicitly saying --prefix=/usr on the ./ line. Furthermore, building at-spi requires an additional --libexecdir=/usr/lib/at-spi on Ubuntu. See for more info.

My suspicion is that if you did not build/install atk/gail/at-spi as above, you've put your system in kind of an inaccessible state. So, please make sure you've built/installed as above and let me know what happens. You may also need to logout and/or reboot[1].


[1] - Well, you could log out and then issue the 'bonobo-slay' command a couple times from a virtual console.

Rich Caloggero wrote:
I'm using ubuntu hardy.
I've rebuild orca, gail, atspi, atk a number of times from svn.
I've deleted my ~/.orca
 test-speech does work - even with viavoice.
The entire startup message spoken is "welcom to orca. starting orca preferences." Question: do I need to explicitly say "--prefix=/usr" on all my ./configure or ./ runs when building atk, gail, atspi, and orca? I noticed that if I leave it off from the run in the orca tree, it places stuff in /usr/local. So, I rebuild orca using prefix=/usr with no luck. I guess I'll try rebuilding everything with explicit prefix=/usr but fear I'll have no better luck. I dont' remember having to do this in ubuntu 7.10. Logginng in from ssh shows two orca processies running; is this normal? Killing and restarting does no good. Sometimes, when I hit control+alt+backspace to return to the login prompt, I get about a half second of speech; can't make out what its trying to say because it dies due to the logout. I'm using gnome-speech - at least I've not been able to start orca so haven't changed this from the default, which I assume is gnome-speech. I'm looking into setting up speech-dispatcher, but not sure it will help. Since test-speech works, I'm assuming the problem is not with the speech system, but some other misconfiguration or something bad about my ubuntu installation. I upgraded from 7.10 (orca was working fine before I upgraded).
 What else can I try?
-- Rich

Orca-list mailing list
Orca-list gnome org
Visit for more information on Orca

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]