Re: Orca complaining


We're still working on getting the right set of dependencies for Orca.
I thought we had them right, but it looks like some things can slip
through the cracks.  :-(  One step at a time, though, and thanks for
your report!

The error you are getting makes me think that you may have an older
version of PyORBit that doesn't have the threading fixes we need.  I
believe you need at least version 2.14.0.  The fact that you are on
Fedora Core 4 raises some red flags - it's pretty old and we're now
requiring people to have at least the GNOME 2.14 release installed,
which I believe comes with Fedora Core 5.

Hope this helps,


On Fri, 2006-06-09 at 19:54 +1000, Jan and Bertil Smark Nilsson wrote:

I installed the latest CVS version of Orca today. I had no problem 
whatsoever. I'm running Fedora core 4 and I didn't get any complaints 
about missing dependencies.

After having run
./ --prefix=/usr
make install
as root, I then went into my home directory and tried to run
orca --text-setup
and got the following message

Traceback (most recent call last):
   File "/usr/bin/orca", line 25, in ?
     import orca.orca
   File "/usr/lib/python2.4/site-packages/orca/", line 37, in ?
     import atspi
   File "/usr/lib/python2.4/site-packages/orca/", line 42, in ?
TypeError: ORB_init() takes no keyword arguments

The same message appears when i run
orca --version

The same thing happens if I run it as root.

What could the problem be?


Bertil Smark Nilsson
Orca-list mailing list
Orca-list gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]