Re: Orca 0.2.4 setting issue

Thanks for your comments, Rich.

Please see my comments inline.
On Wed, 2006-06-07 at 12:06, Rich Burridge wrote:
Hi Tim,

> I downloaded the orca 0.2.4 code and build it on solaris 
> nevada/vermillion_42. But when I type "/usr/local/bin/orca 
> --gui-setup", the GUI preference dialog will not be started. It only 
> sets off the information "Could not initialize connection to braille."
> I did remove the .orca directory in home directory, the speech works 
> well too, the only issue is the GUI preferences dialog. I tried to 
> find help on IRC channel, but nobody answered me. :(
> Does anyone have solution for that?

I've no immediate solution, but I've some comments.

1/ If you don't have a physical braille device attached, then you can 
ignore the
"Could not initialize connection to braille." Orca should work just fine for
speech output even with this message.
I haven't a physical braille device attached, and orca speech works correctly for me.

2/ If you can put the .orca directory back, please do that. Then do into
~/.orca/ and uncomment the three lines:

orca.debug.debugLevel = orca.debug.LEVEL_ALL

orca.debug.eventDebugLevel = orca.debug.LEVEL_OFF

orca.debug.debugFile = open('debug.out', 'w', 0)

Change directories to your home directory, and run "orca --gui-setup" again.
If you are using Orca v0.2.4 (as opposed to the latest from CVS HEAD),
use the F12 key to terminate Orca. Send me the debug.out file that's 
been generated.
If you can't put the .orca directory back, see #3 below.

3/ Does "orca --text-setup" work for you? It should give you a load of 
written to stdout which you will need to respond to. If this works, try 
then following it up
with setting the three debug lines above, followed by running "orca 
(or just "orca -s") afterwards. Does the GUI comes up now? If not, send 
me the debug.out from
the "orca -s " run.
Sorry,  "orca --text-setup" doesn't work for me either.

I'm not sure why this happens. It's strange. After installation of vermillion_42 on snv_41, I could find /usr/bin/orca while others of my colleagues in Beijing Team can not find it on their box.
So I went to orca download page and got the latest orca 0.2.4 source code, installed it on my box with default configure settings. The orca was installed to /usr/local/bin/orca. I tried to invoke the orca gui setting dialog with "/usr/local/bin/orca --gui-setup", but failed.
I removed all the files and directory in my home directory which was created by /usr/bin/orca-setup. Then I run the /usr/local/bin/orca --text-setup again, it still doesn't work.
I tried to generate the .orca directory in my home directory with /usr/bin/orca-setup, and uncommented those three lines, run /usr/local/bin/orca --text-setup again, the output listed below:
bash-3.00$ /usr/local/bin/orca --text-setup
GTK Accessibility Module initialized
Changing debug level to 1000
Changed debug level to 1000
Changing debug level to 0
Changed debug level to 0


orca gui preference still failed to start.



Orca-list mailing list
Orca-list gnome org
Tim Miao
Sun China Engineering&Research Institute
Desktop QE Team

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]