ORBit-WARNING **: No POA found for operation hcmDebug [-1073747064]

This question has been asked earlier, but the final answer never
came up. Is this a bug in ORBit code. (ORBit-mt-0.5.7/RH6.2/glib1.2.10).

The way i can reproduce this bug is (intermittently), i try
to invoke an operation from the client end, the server has just come
up for the first time on the server side. Sometimes, i do get the exception, 
but sometimes there is no exception and my client simply hangs after the 
server has given the following warning

ORBit-WARNING **: No POA found for operation hcmDebug [-1073747064]

The server can entertain subsequent requests without any problem.
(from a new client).

gdb of the client (hung) shows the following stack:

(gdb) bt
#0  0x401aaf50 in poll () from /lib/libc.so.6
#1  0x400bb3b0 in g_main_poll (timeout=-1, use_priority=0, priority=0)
    at gmain.c:1034
#2  0x400badc4 in g_main_iterate (block=1, dispatch=1) at gmain.c:808
#3  0x400bb053 in g_main_iteration (block=1) at gmain.c:907
#4  0x4007aebc in default_wait_for_reply (connection=0x813b038,
    request_ids=0xbfffeb64, block_for_reply=1) at giop-connection.c:470
#5  0x4007ac56 in giop_connection_wait_for_reply_multiple (
    connection=0x813b038, request_ids=0xbfffeb64, block_for_reply=1)
    at giop-connection.c:391
#6  0x4007acc7 in giop_connection_wait_for_reply (connection=0x813b038,
    request_id=3221220232, block_for_reply=1) at giop-connection.c:408
#7  0x80a8415 in hcm_HcmDebugObject_hcmDebug (_obj=0x8130c70, msg=0x8119160,
    ev=0x811c6cc) at hcm-stubs.c:7029
#8  0x80aa037 in hcm_debug_handler () at dbg-clifuncs.c:75

Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]