cannot connect rtl8192fs to wireless network using NetworkManager with wpa_supplicant

Hi all,
i am struggling for a week to connect via NM together with wpa_supplicant using systemd on buildroot. I have compiled wpa_supplicant with dbus support. Before that i tried to use only NM, but the nmcli was saying that the wlan0 interface was unavailable. I was unable even to scan network using nmcli, but iwlist wlan0 scan command was working just great. More over if i use only wpa_supplicant configuration file with this command:

wpa_supplicant -Dwext -i wlan0 -c /etc/ics_2g.conf &

the connection is being established.

The config file for the connection looks like this:



There is one more thing. This rtl8192fs driver needs private parameters to work. Before i call wpa_supplicant command i need to call this 4 commands:

ifconfig wlan0 down

iwpriv wlan0 set_mib opmode=8

iwpriv wlan0 set_mib func_off=0

ifconfig wlan0 up

For NM with wpa_supplicant i have this file /etc/wpa_supplicant.conf:



But the connection isn't being established. I have attached logs from wpa_supplicant and NetworkManager.

Btw. i have also tried to establish connection setting this iwpriv parameters on wlan0 interface but for some reason these are not working for wpa_supplicant/NetworkManager. I was wondering if NM somehow passes it's own configuration to the interface? If yes how can make some modifications?

Best regards
Piotr Łobacz

Softgent Sp. z o.o., Budowlanych 31d, 80-298 Gdansk, POLAND

KRS: 0000674406, NIP: 9581679801, REGON: 367090912

Sąd Rejonowy Gdańsk-Północ w Gdańsku, VII Wydział Gospodarczy Krajowego Rejestru Sądowego

KRS 0000674406, Kapitał zakładowy: 25 000,00 zł wpłacony w całości.

Attachment: NetworkManager.log
Description: NetworkManager.log

Attachment: wpa_supplicant.log
Description: wpa_supplicant.log

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]