Re: Internal dhcp unable to acquire IP from certain routers, breaking network connection for many users


I just tried

nmcli connection modify <conn> ipv4.dhcp-client-id 01:xx:xx:xx:xx:xx:xx

using the MAC address of the adapter and I got an IP. So it seems to be related to the client ID as you suspected.

Strangely, I have been unable to undo this change and getting back to the non-working state for further testing. Tried deleting the setting from system-connections, setting a different insanely long one, rebooting, deleting the lease in the router web interface. Still, I am always getting an IP immediately. Something must be caching this. So for today I am unable to do additional testing.

So I guess Linksys LRT224 is not compliant to RFC4361 then and setting client ID is a viable workaround. Do you consider this case "closed" or do you need additional info for debugging?

Kind regards,

Am 03.01.2018 18:55 schrieb Thomas Haller:
On Tue, 2018-01-02 at 17:57 +0100, Mleman wrote:

thank you for your reply. I will report to the distro maintainers
regarding their compilation defaults.

As for the non-working DHCP handshake, I did as advised and generated
log with level=TRACE and pasted it on


Thanks for the logs.

Looks similar to bug

Does the workaround described there help?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]