"Shared to other computers" question

Several months ago I setup a PC to share a VPN connection among the PCs on my LAN. A CentOS 7 box serves as a "gateway" and accesses the VPN using the openvpn client.

NIC1 connects to my router using DHCP on the router to obtain an IP address such as

NIC2 is set to "Share to other computers". ifconfig shows this device to have the address  By connecting another PC with a hard coded IP address in the 10.42.0.xxx range to a switch and thereby to the dual NIC machine, my second PC can connect to the Internet. MAGIC :-)

I then decided to do a little daisy chaining.  I added a second NIC to the second PC. I configured that interface to "Share to other computers." This connection gained the IP address Cool.

I put the first dual NIC PC in "production" between my Internet connection and my LAN. I installed a DHCP server on the box and it serves up 10.42.0.xxx addresses to my LAN PCs.  Works great and has been in use for about 3 - 4 months.

Today I needed to setup something to do some firewall experimenting.  I plugged a test PC with 2 NICs to my LAN with NIC1. It received an IP address 10.42.0.xxx from my DHCP server. So far, so good.

I configured the second NIC as "Shared to other computers" as described above.  This time the second NIC received the address which will not work. That is the address of the first dual NIC PC.

I have redone this several times. I also tried an Ubuntu 16.04 PC.  I still get the address on the second NIC. I am at a loss.

Was the original 10.43 address a fluke?
Perhaps a newer version of network-manager-applet is hosed?
Something I need to configure manually in the firewall to cause an new subnet to be assigned to NIC2?  I really have no idea where the 10.42 address came from in the first place.

The test PC is running CentOS 7.4 with network-manager-applet

Any advice appreciated.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]