Re: Modem Manager stuck in a loop, ppp can't connect.

On Thu, May 04, 2017 at 09:14:01PM -0500, Dan Williams wrote:
On Sun, 2017-04-30 at 17:26 -0400, A. F. Cano wrote:
I had a similar problem back in January which was discussed in the
thread with title: "Network manager auto-upgraded, ppp no longer

All the information about the device, AT commands and responses can
found there, as requested by Dan Williams.  Something was apparently
fixed and Modem Manager went back to working correctly.

I don't think I was able to fix anything, so it must be something in
the device.  The logs are the same problem as before, the device isn't
returning a valid SID/NID for AT+CSS and thus we cannot figure out if
we're registered on the network or not, and thus whether we can

Mmm...  This is puzzling.  The only thing that changed was an upgrade of
network-manager/modem-manager in the previous installation.  Then that
installation (system on an SD card) became unusable (unrelated problem)
and I installed a new system on a new SD card and it didn't work, again.
Your answer prompted me to try again and, surprisingly, it now works
correctly again.

Just having service (eg, "AT+CSS: 1") isn't enough, because in the CDMA
systems you'll almost always connect to the network for emergency
calls, even if you cannot initiate a data connection.

Thank you for the clarification.  I now understand better what
modem-manager is trying to do and the likely bugs/limitations of this
old phone.

I'd be pretty curious what made things work again, if you have any
command traces from that time?

Not specific log file entries but the version of network-manager on the
old system (where it worked, then didn't and then worked again) was
1.4.something.  The new installation was 1.6.something, but this is
probably coincidental since this one is now working also and I'm pretty
confident that the phone software is buggy.  It sometimes reboots
itself, other times after a data session I have to power cycle the phone
or voice calls can't be made, and I think the charging sofware is also
buggy and is slowly ruining the battery by overcharging, but maybe the
battery is just old.

In any case, thank you for replying.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]