Re: WiFi interface disappeared

On Mon, 2015-09-14 at 17:32 -0400, Jim wrote:

Thanks for replying.  As I mentioned the WiFi on the same box runs fine 
from Ubuntu or from Windows.

Here are the lspci and lsusb

08:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 
802.11b/g/n WiFi Adapter (rev 01)

So you have a Realtek 8188CE device.

In addition, here is lsmod
Module                  Size  Used by
i915                  958755  3
i2c_algo_bit           13250  1 i915
drm_kms_helper         93604  1 i915
crct10dif_pclmul       14307  0
crc32_pclmul           13133  0
crc32c_intel           22094  0
drm                   300858  5 i915,drm_kms_helper
ghash_clmulni_intel    13230  0
r8169                  71639  0
mii                    13527  1 r8169
video                  19825  1 i915
sunrpc                279333  1

This shows there is no kernel driver loaded for your device.  Yes, r8169
is a realtek driver, but it's for ethernet devices not wifi.  I'd expect
to see an rtl81xx (maybe rtl8192) or similar module.  Next step is:

dmesg | grep rtl

and lets see what we get.


On 09/14/2015 03:17 PM, Dan Williams wrote:
On Mon, 2015-09-14 at 14:10 -0400, JimR wrote:
Fedora Core 21, KDE spin, all patches up to date.

Have run for many months using WiFi almost exclusively. Started using OpenVPN a couple of months ago 
with a commercial VPN provider. (Not sure if that matters). That has worked fine.

Got notification from Apper that some packages needed updating, including kernel. Performed the update 
from the Apper UI.  I don't know if Networkmanager was in the list.

After reboot, WiFi no longer works, in fact, the whole WiFi interface has disappeared from ifconfig and 
from the NetworkServices UI. I plugged in an ethernet cable, and it works fine. Machine is triple-boot, 
FC21, Win7 and Ubuntu LTS 14.04. WiFi works fine in Win and Ubu.

I tried re-adding the interface, wlp8s0 using the Connection Editor. Seemed happy, but it still won't 
start nor  list in ifconfig
If the device isn't listed in ifconfig the the kernel cannot see it, and
thus NetworkManager can't see it.  It seems like there is either a
hardware problem with your wifi device, or the kernel has been updated
and no longer recognizes the wifi device.  What is the output of 'lsusb'
and 'lspci' when those commands are run in a terminal on your machine?


I found this in the messages log around the time of the failure, but googling this does not produce any 
meaningful help:

Sep 12 23:16:04 KD1YV1 NetworkManager[733]: <info> (wlp8s0): device state change: activated -> 
deactivating (reason 'removed') [100 110 36]
Sep 12 23:16:04 KD1YV1 NetworkManager[733]: <info> NetworkManager state is now CONNECTED_LOCAL
Sep 12 23:16:04 KD1YV1 NetworkManager[733]: <info> (wlp8s0): device state change: deactivating -> 
unmanaged (reason 'removed') [110 10 36]
Sep 12 23:16:04 KD1YV1 NetworkManager[733]: <info> (wlp8s0): deactivating device (reason 'removed') [36]

_______________________________________________ networkmanager-list mailing list networkmanager-list 
gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]