Re: NM+WPA_Supplicant+Systemd trouble: can't connect to WLAN

On Tue, 2014-09-09 at 05:42 -0400, Pavel Simerda wrote:
----- Original Message -----
From: "Mark Elkins" <mje posix co za>
To: networkmanager-list gnome org
Sent: Saturday, September 6, 2014 10:55:18 AM
Subject: Re: NM+WPA_Supplicant+Systemd trouble: can't connect to WLAN

I run Gentoo and had huge issues when upgrading to Systemd. I chose to
go Mate to get back the old feel. Created the following script which
unless I run, Wifi will not work. ie Things currently currently appear
to start up in the wrong order.

systemctl stop NetworkManager
killall -9 wpa_supplicant
killall -9 wpa_supplicant
systemctl start NetworkManager

You just need to ensure there's no service enabled that would interfere with NetworkManager and after 
reboot everything should be nice and happy. There are a couple of things that are different when using 
systemd but I don't think any of them is specifically related to wifi, except maybe some gentoo specific 

NetworkManager uses DBus to communicate with wpa_supplicant, and if it
doesn't fine a running instance it will spawn one using dbus service
activation.  wpa_supplicant's DBus interface is enabled with the "-u"
command-line parameter at supplicant launch time.

So, if you have a systemd supplicant service that does not have "-u" in
the command-line, it's quite possible that two will get spawned, and
then fight for the wifi card.  Make sure that doesn't happen by always
using "-u" when starting the supplicant.



On Fri, 2014-09-05 at 16:14 -0400, Nickolai Dobrynin wrote:
Dear all,

I've Googled my stomach off and tried to get help on Gentoo
(my distro of choice) forums:

Nobody knows anything, so here I am.  Long story short: I can't
get the NM+WPA_Supplicant+Systemd combo to connect to WiFi.
I depend on a WiFi for my installation and have no wired Internet access.
Everything works via DHCPCD (with NM off), but when I disable DHCPCD
and fire the NM up instead, it creates a WPA Supp instance which says:

wlp3s0: Associated to a new BSS: BSSID=88:dc:96:03:5b:28
wlp3s0: No keys have been configured - skip key clearing
wlp3s0: Select network based on association information
wlp3s0: No network configuration found for the current AP
wlp3s0: Request to deauthenticate - bssid=88:dc:96:03:5b:28
pending_bssid=00:00:00:00:00:00 reason=3 state=ASSOCIATED
wpa_driver_nl80211_deauthenticate(addr=88:dc:96:03:5b:28 reason_code=3)
wlp3s0: Event DEAUTH (12) received
wlp3s0: Deauthentication notification
wlp3s0: * reason 3 (locally generated)

This is happens in response to

  $ iw dev wlp3s0 connect <name>

which I execute manually, and the network is public and unsecured.

Since WPA Supplicant functions well with DHCPCD, this, to me, indicates
a NetworkManager-related issue.

I am seeking as much information as possible on how to troubleshoot this.
Don't know if this is relevant but my wireless driver is iwlwifi.

Many thanks.
networkmanager-list mailing list
networkmanager-list gnome org

Mark James ELKINS  -  Posix Systems - (South) Africa
mje posix co za       Tel: +27.128070590  Cell: +27.826010496
For fast, reliable, low cost Internet in ZA:

networkmanager-list mailing list
networkmanager-list gnome org

networkmanager-list mailing list
networkmanager-list gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]