Re: HP hp3110 HSPA+ Mobile Broadband Module Modem is not shown up

I had this problem with the same card on an elitebook - never could get this to work under ubuntu, it'd only ever expose the first serial port, and would never take the firmware to load the second for the data socket. RFkill said it was enabled, but never *worked*...

Bios was flaky as hell at the time and hp was intent on not fixing it (linux users, meh), so not at all surprised what Bjørn says is true.

I recently updated the bios to sell it, which they released just a year or so ago, which fixed the suspend and crash issues, but haven't tested the rfkill to see if this fixed the gobi too. I also updated ubuntu to 14.04 which came with a host of improvements too that could help - will try and see.

Odd side effect of installing this card at the time was it killed my bluetooth under both windoze or linux, which distinctly worked prior to install of the gobi card. Rfkill didn't even see it.


On 06/18/2014 06:04 AM, Bjørn Mork wrote:
Harald Jung <jung ecos de> writes:


we were in touch with a HP notebook which is shipped with a broadband
The device should be a "HP hp3110 HSPA+ Mobile Broadband Module Modem"
which isn't visible on the usb bus nor the pci bus.
Booted up with windows the device is visible and working.
Have you ever heard about a problem like this?
Yup.  Exact details are a bit fuzzy in my memory, but I believe this is
a BIOS (or whatwever the current "PC firmware" buzzword is) problem.
The modem is problably disabled by the PC firmware rfkill ("flight
mode") implementaion.  This means that you need a platform specific
driver to enable it. It is not a modem driver problem but a *laptop*
driver problem.

You should looking at the loaded platform rfkill driver(s).  Is this
'hp-wmi'? Does 'rfkill list' show anything useful?  Are there physical
switches you can toggle?

networkmanager-list mailing list
networkmanager-list gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]