Re: QMI and LTE: IP connection problems

"Martin Anderseck" <Martin Anderseck ni com> writes:

I'm testing around with a Sierra Wireless MC7710 in QMI mode. For this
I've checked out, built and installed the current versions of
ModemManager and NetworkManager a few days ago. First tests with two
different UMTS networks were successful. Great work, this really works
out of the box both with QMI and AT commands (Sierra Wireless
SW/DirectIP mode)!

For further tests I'm using a communication tester for LTE
signaling. Currently this fails at the simple IPv4 connection. I think
I can exclude the communication tester as the connection works
flawlessly using the module with AT commands in the SW/DirectIP mode.

So what is happening in QMI: The module gets attached and gets an IP
address with the default bearer. Setting up a connection either using
the NetworkManager or mmcli --simple-connect works. Binding this IP
address to wwan0 using dhclient works, too. But while after this
procedure with AT commands (SW/DirectIP mode) I can ping my APN, use
services which the communication tester provides and so on, no
IP-based communication is possible when having set up the connection
via QMI.

What have I done already: 
- Checked output of ifconfig wwan0. Differences in the netmask: In AT
mode the netmask is, in QMI it's I
don't know yet if this could make the important difference as in
general the UE only needs to connect to its gateway which can be done
with a rather limiting netmask, too.
- Changed configuration of wwan0 to the data which works for the AT
mode - no success.
- Tried pinging the UE from the communication tester using a built-in
ping functionality. It got pongs back when the UE was attached but
stopped as soon as I connected the UE using the NetworkManager or
mmcli --simple-connect. When I disconnected the pongs re-appeared. I
cannot explain this to me in any way...

Does anyone of you know what could be the problem in this setup? Can I
provide you with more information or log files to narrow the down
problem? Which parts of the ModemManager log is crucial?

So it
- works with DirectIP
- works with QMI and UMTS
- fails with QMI and LTE, except for DHCP

This pattern matches the firmware bug worked around by this commit:

It has been backported to a number of stable kernels, but as it is
pretty new there are chances you haven't got it yet.  If not, then the
first thing you should try is a kernel with that patch.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]