Re: Hello, please help with my 3G device

The Huawei plugin always starts probing USB interface 0; and it seems
that none of the 3 ttyACM ports given has usbif 0, so never starts
probing the other ports. The plugin should possibly wait up to N
for usbif 0 to appear, and keep on probing normally if it doesn't
in that time.

Will try to prepare a patch for that.

Great! cannot wait to try :)

Attached is a patch to apply on top of the MM_05 branch of ModemManager:
    $> git clone git://
    $> cd ModemManager
    $> git checkout -b MM_05 origin/MM_05
    $> git am /path/to/the/patch.diff
    $> ./ --prefix=/usr --sysconfdir=/etc --localstatedir=/var
    $> make
    $> sudo make install

It is not a perfect solution, but should do the trick. I'll find a
better fix for git master/0.7; as I do have some probing improvements
ready there which would help quite a lot also in this case.

Let me know if it worked or not, as I don't have any Huawei modem around
to play with. Please attach debug logs in any case.

Hello, it partially works.

I can find the device in nm now, but when try to connect to 3g net, it

Seems we're mixing up which is the port we use for control and the one we
use for PPP. Can you run "AT^GETPORTMODE" with minicom in each of the

I suppose you mean ttACM*?

I tried and all of them returned simple 'ERROR', seems not support that AT
command. and I do it while connecting to 3g net via wvdial, the result is
different: ACM0 just says locked, ACM1 respones the same to the situation
when offline, ACM2 instantly return some '^DSFLOWRPT' and '*PHBI'.

Ah wait, just found an error in your setup. When selecting a number to call in the connection profile, do *not* explicitly list the PDP context to use, so don't write "*99***1", write instead: "*99#". It seems we're building the wrong ATD call if you explicitly select the PDP context:

(ttyACM0): --> 'ATD*99***1***2#<CR>'
(ttyACM0): <-- '<CR><LF>+CME ERROR: 3<CR><LF>'

Just provide a proper APN to connect to in your connection profile, and MM will try to create the PDP context if it doesn't exist or just connect to an already available one.

The ports mismatch may end up not being an issue here as there seems to be no mismatch (ttyACM0 really seems to be the port to use for control).


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]