Modems access fails after pppd hang up


after doing a lot of testing with bad UMTS connections, I was able to solve most of my problems with my patches from .

There is one problem still left, which I am not able to solve on my own.

If pppd hangs up for whatever reason (for example because of on lcp echo failure), often the modem remains in an unusable state, because the modem is still in data mode and modem manger tries to send AT commands and does not get an answer.

In this state it often helps to disable UMTS at all (using the right mouse menu) and enable it again. Then the modem gets reseted and everything works again.

I have tried to automatically disable/enable the modem in case there is no response to the AT commands and also tried to send flash or AT hangup command on the secondary line (as far as available), but I was not able to get the different state machines of network manager and modem manger to do the right thing.

I have found this behavior with at least 5 different UMTS modems, so I think it's a general issue.

At least from my point of view it would be very imported to automatically recover from errors (as far as possible).

Since I didn't found a solution I would need an idea or a pointer what can be done to make modem manger better handle such situations.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]