Re: Unable to connect to mobile broadband: +CME ERROR:30

Am Mittwoch, den 13.10.2010, 12:49 +0200 schrieb Dan Williams
<dcbw redhat com>:
> On Mon, 2010-10-11 at 10:43 +0200, van Schelve wrote:
>> Hi,
>> I found a different problem where I get reports from our users in the
>> field. They tell us that they are not able to connect to mobile
>> network.
>> In the logs I captured I found a cme error 30 which means "No network
>> service". I tried it two or three times with still the same problem.
>> Then I tested with a second identical laptop with an identical setup
>> and I was able to bring up the mobile connection on this system without
>> any problem.
>> So I decided to use the rfkill switch on the laptop where I found the
>> problem with the result that dialin was possible after doing th rfkill
>> cycle.
> Interesting; your module seems to have firmware, while I have 3
> different modules with,, and  I think
> screwed my device though, so don't try it.  I've noticed odd
> problems like this on other Sierra devices in the past that were solved
> by firmware updates (AC875 and AC881), but it's pretty hard to find
> firmware upgrades for their  embedded modules.  Do you know offhand if
> any of the devices in the field has other firmware than

We have completely identical hardware in the field. All the systems are
Lenovo Thinkpad T61 with identical BIOS 2.10 version and the same
on the embedded sierra device : I think changing the firmware
a different version woud be a really bad option. Our systems are spread
all over germany and I don't think the firmware update would be
under linux.

On the other hand it was good luck that I was able to see this issue on
my system. I'm thinking about enabling debug on all our systems this

[D-BUS Service]
Exec=/usr/sbin/modem-manager --debug >>

and starting NetworkManager --log-level=debug in the upstart initscript

What do you mean? Would this be ok?

> In any case, I'll add some code to ModemManager to get better Sierra
> device status for GSM devices to help debug this issue.  If you run into
> this problem yourself, we want the output of AT!GSTATUS? to get more
> info if you can.

But this means I need to disable mobile broadband temporary because
the serial port is blocked by modem-manager and I cannot get the
information at
the same time. Having more debug in sierraplugin would be very helpful
I have seen other issues that I have not reported yet (for example SIM


> Dan

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]