nm-connection-editor's "Available to all users" checkbox

I can't figure out why nm-connection-editor's "Available to all users"
checkbox is not working for me. I have the following behavior in two
use scenarios:

1. Wireless/Add: receive "Connection add failed: Insufficient privileges"
error dialog when I click "Apply" with "Available to all users" checked.

2. Wireless/Edit: fails silently. That is, I click "Apply" and receive no
error. But, when I again edit the connection, I see that the "Available
to all users" is not checked.

I would expect to be prompted for a root password when I click
"Apply." I would also expect to see some type of error message in the
second scenario.

I am able to add or edit a system-wide configuration if I run "pkexec
nm-connection-editor --display=:0.0" and provide my root password.

My user account is stored in LDAP. I have tried adding myself to the
desktop_admin_t and desktop_user_r groups (by editing the local /etc/group
and confirming with the groups command), but this does not help.

I am using Fedora 14 and have the following related packages installed:




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]