Re: [solved] HUAWEI E220, connection problems.

Dan Williams wrote:
On Tue, 2009-11-24 at 11:27 +0100, Alexey Fisher wrote:
Am Montag, den 23.11.2009, 23:10 +0100 schrieb Alexey Fisher:
Am Montag, den 23.11.2009, 13:55 -0800 schrieb Greg KH:
On Mon, Nov 23, 2009 at 09:51:07PM +0100, Alexey Fisher wrote:
Hallo, i have HUAWEI E220 (Vodafone/Germany) and i have some random problems to
connect it on ubuntu karmik.
First of all, this do not working with 2.6.31. But you probably know it.
Doesn't solve the E220 issues?
Oh... only God and Shuttleworth know what 2.6.31-14-generic is. Alexander, do ubuntu 2.6.31-14-generic ==

I use now recent master git 2.6.32-rc8-00011-ga8a8a66 and it is getting
connected some times. If i plug it, it will take like about 30-60
seconds till NM will start it. Normally first time the connection will fail, some times it will work on
second try. If you try too mach, this will not work at all.. only reboot
will help.
Well, that's better than the old 2.6.31 problem :)
Mia culpa, mia maxima culpa...
Dr. Google say i need update firmware. Newer thought there is firmware
and need to be updated :( Now it's working.

Is it *actually* an E220?  Huawei uses the same USB IDs for different
devices.  What's the model # that's printed on the device?  (my E160G is
*also* 12d1/1003 for example)

In any case, what firmware version did you update to that made it work?

Version from my provider worked:

Unfortunately there is no 'official' version from Huawei since they only make the updates available via the network operators.

I'd like to note the correct version on the NM mobile broadband wiki


NetworkManager-list mailing list
NetworkManager-list gnome org

Graham Beneke
E-Mail/MSN/Jabber: graham apolix co za   Skype: grbeneke
VoIP: +27-87-550-1010                    Cell: +27-82-432-1873

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]