Re: org.freedesktop.NetworkManagerSystemSettings was not provided by any .service files.

On Mon, 2009-02-02 at 17:59 +0800, 代尔欣 wrote:
> Hi all, 
>     I port the NetworkManager(revision 3202) and applet(revision 425)
> to our embedded device. So far it works fine. From the 
>     I saw the official 0.7 is already released. So I am trying to
> upgrade our version. I have several questions. Thank help in advance.
> 1. I download the applet from
> Is it the correct version work wit h NetworkManager 0.7.0?
> 2. After upgrade some packages(dbus1.1.1 dbus-glib0.7.6 etc.). I can
> compile and install the NetworkManager and nm-applet. When I run the
> nm-applet, I get below warning:
> ** (nm-applet:3735): WARNING **: Icon nm-device-wwan missing: Icon
> 'nm-device-wwan' not present in theme
> --It seems the applet search the gnome icon theme but not the icons
> nm-applet installed. 

What --prefix did you use when you installed it?  Check to be sure they
are in /usr/share/icons/hicolor.  You'll also want to make sure the GTK
icon cache is updated by doing:

gtk-update-icon-cache -f /usr/share/icons/hicolor

> ** (nm-applet:3735): WARNING **: Could not retrieve dbus connections:
> The name org.freedesktop.NetworkManagerSystemSettings was not provided
> by any .service files.
> --I checked. It
> seems /usr/share/dbus-1/system-services/org.freedesktop.NetworkManagerSystemSettings.service already installed. why?

It may be that dbus system activation is not working correctly on your
system.  Or, see below, you probably don't have the necessary config
file for nm-system-settings.

> ** (nm-applet:3114): WARNING **: couldn't communicate with gnome
> keyring daemon via dbus: The name org.gnome.keyring was not provided
> by any .service files
> --The gnome-keyring-daemon already run.

Yeah, looks like D-Bus isn't set up correctly on your system.

> 3. Related question2 the first warning, nm-connection-editor can't be
> run. Below warnings:
> ** (nm-connection-editor:3858): WARNING **: Icon nm-device-wwan
> missing: Icon 'nm-device-wwan' not present in theme

Same thing; the connection editor uses the icons from the applet too.
Fixing the icon cache thing will fix this too.

> ** (nm-connection-editor:3858): WARNING **: Failed to initialize the
> UI, exiting...
> 4. Related question2 the second warning, I run 
> /usr/sbin/nm-system-settings
> --config /etc/NetworkManager/nm-system-settings.conf
> manually, I got
> ** (nm-system-settings:3946): WARNING **: Invalid config file: No such
> file or directory.
> I checked, no conf file in /etc/NetworkManager/ where can find this
> file? What is it for?

You may need to create it.  It provides system-level connections to
NetworkManager, which can be used before login, and across logins.  For
your case, it should probably just contain:


and then it should work for you.

> 5. NetworkManager0.7.0 work with PolicyKit. Which policykit version
> should I use? PolicyKit0.6? Now I use PolicyKit0.9, but need replace
> the function 
> polkit_context_can_caller_do_action(deprecated) with
> polkit_context_is_caller_authorized

Hmm, that should already be working correctly for you, since those calls
are already protected by checks for PolicyKit version.  Do you have the
correct PolicyKit development headers
(including /usr/lib/pkgconfig/polkit.pc) installed?  What version do you
get when you run:

pkg-config --modversion polkit


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]