Re: PPPoE connection uses wrong NIC

I got the source for my distro's release,

I then hacked it to use ib0 instead of nic-eth0 if the username
contains This works fine and pppd is launched with the
correct nic.

Though when the get_credentials function is called in
nm-pppd-plugin.c, the dbus_g_proxy_call function times out and I get
this message: Looks like pppd didn't initialize our dbus module

The first time I ran this I got a dialog popping up asking me if I
want to allow the secrets retrieval. I accidently pressed "Always
Allow" and can't find the place where I can disable this. So I'm not
sure if this even happens anymore.

I also checked auth.log, and I don't see any message denied errors. In
fact, I don't see ANY dbus messages being sent other than the
notification about the wired connection going down.

Though I am still not able to get the DBUS call to work. So I have 2 questions.

Question 1: Is the DBUS connection in anyway related to the interface
bound to, in this case nic-eth0? Meaning if I use ib0 the dbus will

Question 2: Any extra information/ways I can debug why this call is not working?

Beyond this if I hack get_credentials and hardcode the return of the
password if the username contains everything works fine
and my connection is established. So doing this I'm able to get
NetworkManager to manage my iburst connection, which makes life much
easier when I change other network settings like unplug/plug the
ethernet cable. Previously I would loose my internet connection
because my routes/resolv.conf would be modified. Now this works well
because both connections are managed by NetworkManager.

I would just prefer to not hardcode my passwords, because I change
them every few weeks and have more than one account. Which means that
my changing parameters would require a rebuild and reinstall
everytime. Is there perhaps another way I can retrieve the password
entered into the Edit Connections dialog? (other than the DBUS call
that is). I don't mind a bit of hacking to get this working while it's
being integrated into the main branch. Though I would really prefer to
not have to add an extra step into the process, and have all my
configuration happen purely via the nm-applet.

Quintin Beukes

On Tue, Dec 29, 2009 at 1:40 PM, Quintin Beukes <quintin last za net> wrote:
> Thanks for the quick response. I'll grab the source and do it this way for now.
> On the topic of the iBurst driver rewrite. Where can I get more
> information on this?
> Quintin Beukes
> On Tue, Dec 29, 2009 at 1:32 PM, Graham Beneke <graham-ml apolix co za> wrote:
>> Quintin Beukes wrote:
>>> I am trying to connect to a wireless-broadband provider using an
>>> iBurst modem. The driver creates a network device, which reports
>> If you dig through the archives you'll find a number of mentions of this
>> issue. The devs are aware of the problem and there is work being done to
>> support PPPoE on interfaces other than eth0. I'm not sure what the current
>> progress is on this.
>> There is also some work being done to rewrite the iBurst driver and get it
>> rolled into the kernel but that has been a little slow.
>>> itself as a wireless device (so iwconfig lists the signal strength).
>>> It's not a GPRS/3G, so I can't take the wireless-broadband steps in
>>> the connection editor. The DSL steps should work perfectly, except the
>>> nic passed to pppd is my ethernet device instead of the one created by
>>> the driver. PPPoE must happen via this device, where the driver will
>>> pass it onto the modem via USB and the rest happens as usual.
>>> Either way, when NetworkManager invokes pppd, it does it as follows:
>>> Dec 29 12:31:47 quintin-VIAO NetworkManager: <debug>
>>> [1262082707.053800] nm_ppp_manager_start(): Command line:
>>> /usr/sbin/pppd nodetach lock nodefaultroute user <my-user> plugin
>>> nic-eth0 noauth nodeflate usepeerdns mru 1492 mtu 1492
>>> lcp-echo-failure 3 lcp-echo-interval 20 ipparam
>>> /org/freedesktop/NetworkManager/PPP/8 plugin
>>> /usr/lib/pppd/2.4.4/
>>> As you can see, is passed the parameter nic-eth0. This
>>> should instead be ib0. If I copy this line and remove the
>>> nm-pppd-plugin and change the nic-eth0 to ib0 I can connect (in fact,
>>> that's how I sent this e-mail).
>>> How can I configure network manager to use the correct nic?
>>> My current configuration file:
>>> [connection]
>>> id=iBurst
>>> uuid=60d71ae5-7c0e-4bf9-a338-939fe95585b2
>>> type=pppoe
>>> autoconnect=false
>>> timestamp=0
>>> [ppp]
>>> noauth=true
>>> refuse-eap=false
>>> refuse-pap=false
>>> refuse-chap=false
>>> refuse-mschap=false
>>> refuse-mschapv2=false
>>> nobsdcomp=false
>>> nodeflate=false
>>> no-vj-comp=false
>>> require-mppe=false
>>> require-mppe-128=false
>>> mppe-stateful=false
>>> crtscts=false
>>> baud=0
>>> mru=1492
>>> mtu=1492
>>> lcp-echo-failure=0
>>> lcp-echo-interval=0
>>> [ipv4]
>>> method=auto
>>> ignore-auto-routes=false
>>> ignore-auto-dns=false
>>> dhcp-send-hostname=false
>>> never-default=false
>>> [pppoe]
>>> username=Anita_Geber iburst co za
>>> password=080889SH
>>> [802-3-ethernet]
>>> speed=0
>>> duplex=full
>>> auto-negotiate=true
>>> mtu=1492
>>> I tried adding a mac-address line to the ethernet section, but this
>>> results in the connection being marked as invalid, and not being
>>> available.
>>> Quintin Beukes
>>> _______________________________________________
>>> NetworkManager-list mailing list
>>> NetworkManager-list gnome org
>> --
>> Graham Beneke
>> E-Mail/MSN/Jabber: graham apolix co za   Skype: grbeneke
>> VoIP: +27-87-550-1010                    Cell: +27-82-432-1873
>> _______________________________________________
>> NetworkManager-list mailing list
>> NetworkManager-list gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]