Re: knetworkmanager stopped working

> > When I start nm-applet from console, I receive the following error message:
> >
> > ** (nm-applet:8134): WARNING **: <WARN>
> > applet_dbus_manager_start_service(): Could not acquire the
> > NetworkManagerUserSettings service as it is already taken.  Return: 3
> >
> >
> > (nm-applet:8134): GLib-GObject-CRITICAL **: g_object_unref: assertion
> > `G_IS_OBJECT (object)' failed
> Was KNetworkManager running at the same time?

Thank's everybody for help, I have solved my problem.

In no way anybody in this list could guess the reason of the issue, but
the guiding questions did help to find it.

The reason of the problem was that I had networkmanager-kde4 plasmoid installed
in my system. Even though I did not have it added to my deskop, it still somehow
prevented knetworkmanager from working normally (and also nm-applet to start).
I have removed the package from the system, and magically, all started to work
- first, I was able to start nm-applet in kde, then I knetworkmanager
again started
to work.

Just for history (if someone is interested or would ever find this
thread while solving
the same problem). I have came to this solution while trying to start
nm-applet under
kde. Initially, when I tried to start it in kde4, I did receive the
above error message,
so for clearance I have tried to start lightweight wm (icewn), did
start nm-applet there
and it worked (though my icewm does not have tray and I could not see the icon,
but there were also no errors in the console output). Then I killed
nm-applet, started
knetworkmanager, started nm-applet and it did show the same error as
described above, so
I understood that knetworkmanager does prevent nm-applet from starting.

But when I tried to repeat the same in KDE4, this did not work - I
killed knetworkmanager,
then I even removed it from the system and rebooted - nm-applet still
could not start in KDE4.
And then I have remembered about networkmanager kde4 plasmoid - that
was the last thing is
the system which  could do lock resources from nm-applet, as
knetworkmanager (kde3) did.
I have removed this package from system and all works now.

Thank's again

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]