NM 0.7 Debian Lenny - strangest issue... (Update)

So, it's solved... well, sort of. Maybe this is a known issue, I was reading about alot of problems with resolvconf. Basically, today at work using a wired connection I was able to reproduce the issue below. Being able to connect, get an IP, and even use the IP but completely unable to resolve any IP to name. I found I was able to connect flawlessly to websites using their specific IP and not the Domain Name. So, that pretty much narrows down the problem to a resolving issue with the DNS.

Bottomline, I uninstalled resolvconf - maybe not the most elegant solution... but nm 0.7 works fine now. I don't know how long I'll be able to leave it like this, but at least the problem is located.

Are there any ideas or workarounds for this situation?


Daniel Caleb wrote:
Ok, I've been all over google looking for the answer to this - so if it gets answered in 3 lines, I'm going to kick my own a$$...

I've been struggling with getting nm 0.7 installed, and working, on Debian Lenny. I'm using Bielb's repos the 0.7.0~svn3758-1, or at least trying... a 2.6.25-4 kernel, and a broadcom 4306 wireless card. With NM 0.6.6 everything works as expected.

I am trying to connect to an open wireless AP, the applet reports a connection and everything seems to be fine... I can ping the gateway, I can ping public DNS servers ( & .2). It would appear I am getting out... However, if I do a nslookup or open a browser - no love. nslookup reports connection timeout, and hitting a web page gives a similar result.

I have tried editing the dbus-1/system.d/ files to ALLOW on all instances of DENY, and that did not help - I don't even know if those problems are related however I was out of other things to try... :) The only noticeable entry in syslog after the connection is made is:

Jul 6 01:27:38 allone NetworkManager: <info> DHCP returned name servers but system has disabled dynamic modification!

& this one:

Jul 6 01:27:38 allone NetworkManager: <WARN> check_one_route(): (wlan0) error -34 returned from rtnl_route_del(): Missing link name TLV (errno = Invalid argument)

--- Also, perhaps related, perhaps not... when I launch the nm-applet I get GTK assertion failures, however everything seems to function. The connection editor will crash repeatedly though when trying to modify the current connection. Also, nm-applet had to be restarted in order for settings to take effect.

Tonight I needed my wireless so I am back to 0.6.6, however tomorrow while at work I can get on the wired lan and continue to try to get 0.7 up. If you guys have any ideas I'd love to hear them...


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]