Re: Fedora 8: NM refuses to see wireless networks

On Sun, 3 Feb 2008 17:49:09 +0000
Brian Morrison <bdm fenrir org uk> wrote:

> Hi all
> After some time I've finally got round to loading F8 onto my laptop,
> it's wireless card uses the Intel 3945 chipset.
> I've got it to a state where it can scan for, and find, my home
> networks, iwlist wlan0 scan returns two cells, one my 802.11b AP and
> the other my 802.11g AP.
> However, with NM activated, it works OK for wired networking, but if I
> pull out the cable it simply tells me that the cable is disconnected
> and makes no attempt to enable the wireless network.
> I have added the options iwl3945 disable_hw_scan=1 entry in
> /etc/modprobe.conf and the laptop has been rebooted.
> The only question I wonder about is whether I need to have the
> wpa_supplicant started automatically using
> the /etc/rc.d/init.d/wpa_supplicant script or whether this causes
> problems.
> I've checked that /usr/share/dbus-1/system-services/ has the correct
> wpa_supplicant incantation in it. I've also checked that
> wpa_supplicant.conf has the correct network block with the psk key
> entered correctly.
> When I try to manually ifup wlan0, I'm seeing this message:
> "error for wireless request "set mode (8B06)". Set failed on device wlan0.
> invalid argument. 
> Any assistance most welcome.

As a followup, I have now been successful in getting my laptop to
associate with my AP, but exactly which step fixed it I'm not clear

I disabled wpa_supplicant from running as a service with chkconfig,
installed various bits of pam_keyring and gnome_keyring, edited
the /etc/pam.d/gdm file as suggested at
and then had one failed attempt where I was continually asked for the
password (PSK) for the network after which a further attempt worked
when I remembered to actually stop the wpa_supplicant service (I had
already added the PSK to the wpa_supplicant.conf file so it must have
been obtained from there as I wasn't asked again) and
suddenly...blissful wireless connection! Now, here's hoping it will
survive after a reboot!

If I have one criticism of NetworkManager, it's that the detail of
setting it up is hard to find, I must have read 20 howtos that didn't
actually quite explain everything just right. It's really simple until
the turn it on and let it loose approach doesn't work, then it's
difficult to know what might be the problem, especially as Fedora tends
to be changing underneath everything.

If only I had a clearer understanding, I'd try to remedy that myself.


Brian Morrison

bdm at fenrir dot org dot uk

   "Arguing with an engineer is like wrestling with a pig in the mud;
    after a while you realize you are muddy and the pig is enjoying it."
GnuPG key ID DE32E5C5 -

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]