Re: feedback on attempting to build network-manager from Subversion

On Tue, 2007-03-13 at 20:48 -0400, Mark Stosberg wrote:
> I tried to build NetworkManager from SVN tonight, to see if the latest
> version fixed this bug already:
> >From this ChangeLog entry, it appears that might be fixed:
> ##########
>  * src/nm-device-802-11-wireless.c: Fix wireless device scanning
> scheduler.	The new algorithm is to start from SCAN_INTERVAL_MIN
> (currently defined as 0)	and add a SCAN_INTERVAL_STEP (currently 20
> seconds) with each successful scan	until SCAN_INTERVAL_MAX (currently
> 120 seconds) is reached. Do not scan while	the device is down,
> activating, or activated (in case of A/B/G cards).Remove some old dead
> ifdef'ed out code that used to configure wireless devices, it's all done
> through supplicant now.
> ##############

Likely not.  The old 0.6.5 code followed approximately the same
algorithm.  I suspect driver issues; if the driver is dropping
association during a scan, then the driver needs to get fixed.  An easy
way to test this is to set up a plain wpa_supplicant association, and
then do successive 'iwlist eth0 scan' events every 5 or 7 seconds and
see if wpa_supplicant gets a disconnect event from the driver.


> However, I ran into some barriers trying to install the latest version.
> First, the website refers to CVS, when the latest code is in Subversion now:
> For me, the experience on Ubuntu when more like this instead:
> sudo apt-get install subversion gnome-common checkinstall
> svn checkout NetworkManager
> ( Checkinstall would have been useful for creating a package of the CVS
> version, but I didn't actually get that far ).
> It seems "gnome-common" isn't all that a vanilla system needs to compile
> this. I also get these failures from the autogen script on Ubuntu Edgy:
> checking for glib-gettext >= 2.2.0...
>   testing glib-gettextize...
> not found.
> ***Error***: You must have glib-gettext >= 2.2.0 installed
>   to build NetworkManager.  Download the appropriate package for
>   from your distribution or get the source tarball at
> Checking for forbidden M4 macros...
> ***Error***: some autoconf macros required to build NetworkManager
>   were not found in your aclocal path, or some forbidden
>   macros were found.  Perhaps you need to adjust your
> #############
> If someone knows the extra steps missing, it would be nice to update the
> website to reflect them.
> ( And of course, I'm still curious to find a solution the frequent
> disconnect/reconnect bug!)
>     Mark
> _______________________________________________
> NetworkManager-list mailing list
> NetworkManager-list gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]