Atheros, networkmanager fails

I have a strange wireless problem.  I run an up to date Debian Etch on a T42p thinkpad.  I had wireless working using network-manager with madwifi. For some reason it stopped working.  I just figured some update broke it. lspci shows:

Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC
(rev 01)

The strange thing is that my thinkpad developed a system board problem and had to be repaired.  My hard drive was put into a T42 loaner.  The loaner T42 had an Atheros AR5211 controller.  Wireless worked with the loaner under network-manager.  I noticed it used ath1 instead
of ath0 like my regular laptop always did.  When I got my regular laptop back, wireless under Linux still didn't work and it was using ath0 again.  I verified that wireless does work when I boot into Windows.

What I don't understand is why for no reason did my original laptop wireless quit working?  Why did the loaner use ath1 instead of ath0?  Is ath0 somehow tied to the controller hardware address of my regular laptop so the loaner with a different controller hardware address used ath1?  Is there some bad configuration information stored somewhere for ath0 causing it to not work?  If so, how can I clear it out.  I use
udev. Network-manager is nice when it works but if it doesn't work, it seems hard to debug since it hides everything.  Any ideas on how to debug this problem?

madwifi-source 1:0.9.2+r1842.20061207-2
network-manager 0.6.4-6

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]