Unknown problem with NetworkManager, No devices found.

Hello list,

Networkmanager does not work on my PC, and it has been like that for
some weeks now. I was waiting for it to be fixed in a later release, but
it seems it's a local problem, every version i try has the same problem.

nm-applet says that no devices are found, and when i start NetworkManger
--no-daemon, this is my output:

laptop gentopia # NetworkManager --no-daemon
NetworkManager: <information>   starting...

Nothing else!

If i look at dbus-viewer or dbus-monitor there is no sign of
NetworkManager actually communicating with anything. It's just as silent
as a lamb.

I have tried with alot of different versions, 0.6.0, 0.5.1, 0.5.2 and
even CVS. I run Gentoo, with dbus-0.60, and hal 0.5.6-r2. This is the
libraries it's linked against:

laptop gentopia # ldd /usr/sbin/NetworkManager
        linux-gate.so.1 =>  (0xffffe000)
        libhal.so.1 => /usr/lib/libhal.so.1 (0xa7f23000)
        libiw.so.28 => /lib/libiw.so.28 (0xa7f1c000)
        libnl.so.1 => /usr/lib/libnl.so.1 (0xa7eec000)
        libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0xa7ee7000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x4a8e1000)
        libnm-util.so.0 => /usr/lib/libnm-util.so.0 (0xa7ede000)
        libdbus-glib-1.so.2 => /usr/lib/libdbus-glib-1.so.2 (0xa7ec3000)
        libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0xa7e83000)
        libdbus-1.so.2 => /usr/lib/libdbus-1.so.2 (0xa7e58000)
        libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0xa7dc2000)
        libgcrypt.so.11 => /usr/lib/libgcrypt.so.11 (0x4bd22000)
        libnsl.so.1 => /lib/libnsl.so.1 (0x4b4ea000)
        libgpg-error.so.0 => /usr/lib/libgpg-error.so.0 (0x4b8e5000)
        libc.so.6 => /lib/libc.so.6 (0x4a695000)
        libm.so.6 => /lib/libm.so.6 (0x4a7b1000)
        /lib/ld-linux.so.2 (0x4a67c000)

uname -a:
Linux laptop 2.6.16-rc3-nitro1-haz #1 PREEMPT Fri Feb 17 22:44:09 CET
2006 i686 Intel(R) Pentium(R) M processor 1.50GHz GenuineIntel GNU/Linux

Please, i need help to how i can find the source of this problem.

Kind regards,
Johan Christiansen

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]