Wireless Connection Troubles

I asked about this some time back and didn't see any thing other than a
follow-up "is this a good idea" from Dan.  I'm wondering if there are any
others having similar issues...

I have one customer site that has a ton of laptops.  Some are sedentary
and hard-line connected but their wireless card are active.  It appears
that some of them are set to the same ESSID as the local
Infrastructure-mode wireless network but they are set to AdHoc mode.
Further, the APs are setup to hide their ESSIDs.  When I run 'iwlist eth1
scan', I see one AP (Mode:Master) with ESSID:"<hidden>" and one or more
other machines with ESSID:"foo" and Mode:Ad-Hoc.  At this point, the AP's
power level is lower.

I blew away all of the previous /system/networking/wireleww/networks
entries in gconf.  I fired up NetworkManager and nm-applet.  I see no
entries in the applet menu for wireless networks.  I told it connect to
the "foo" network and it always uses the AdHoc network.

I looked into hacking the code myself to have it ignore AdHoc networks and
think I may have done it but I still can't connect to the AP.  I added a
couple lines in the nm_device_wireless_process_scan_results() routine.
Basically, it adding all ADHOC APs to the outdated_list just like it's
doing for those where ap_time exceeds 180 seconds ago.  After installing
this change, I tried to reconnect.  Using `watch iwconfig eth1`, I now see
the card set to Managed mode and connected to the MAC address of the AP.
When I run tcpdump on the interface, I see the BOOTP request but no
response.  I am also seeing some non-IP traffic and VRRP packets from one
of the routers over here.

I should add that I am able to connect to a couple APs at home, a few
other customer sites, the coffee shop, my mechanic's waiting room, etc.  I
don't recall any of them coming up <hidden>.  Is this the problem.  I've
read that hiding ESSIDs is not approproate but I have no control over that

I'm speding more and more time at this customer so the lack of wireless
connectivity is a pain.  It's also embarassing as the lone Linux guy.
When I boot windows on this machine, I can connect fine!  Grrrrrr......

Paul Dugas, Computer Engineer           Dugas Enterprises, LLC
paul dugas cc     phone: 404-932-1355   522 Black Canyon Park
http://dugas.cc     fax: 866-751-6494   Canton, GA 30114 USA
Onsite at GDOT W.Annex 404-463-2860 x199

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]