gconf _entry_unref patch



Hi,

I just downloaded and attempted to build the CVS NetworkManager sources. During compilation, I got a warning about an implicit declaration of "gconf_entry_unref" in gnome/applet/applet-dbus-info.c.

I upgraded to the latest version of gconf (1.2.1). This still didn't solve the problem.

I looked around a bit, and found that there was little documentation, but after reading the gconf source a little, it would seem that gconf_entry_free should be called instead of gconf_entry_unref. I'm reasonably sure that this is correct, but someone might like to check.

So, anyway, here's a patch for NetworkManager that fixes the warning. I believe it's a patch against 1.2.5.

Rob.

diff -u -r1.25 applet-dbus-info.c
--- gnome/applet/applet-dbus-info.c	24 Oct 2005 23:03:42 -0000	1.25
+++ gnome/applet/applet-dbus-info.c	30 Nov 2005 17:07:38 -0000
@@ -941,7 +941,7 @@
 			gnome_keyring_attribute_list_free (attributes);
 		}
 
-		gconf_entry_unref (gconf_entry);
+		gconf_entry_free (gconf_entry);
 
 		key = g_strdup_printf ("%s/%s/essid", GCONF_PATH_WIRELESS_NETWORKS, escaped_network);
 		gconf_client_set_string (applet->gconf_client, key, essid, NULL);


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]