Re: nm freezes system with nm-vpnc

Tim Niemueller a écrit :

>Versions of vpnc, NetworkManager and distro
Ubuntu dapper, nm 0.5.1 packages from
vpnc 0.3.3

The same happened while using nm 0.4.1CVS from ubuntu universe repository.

>vpnc does not support re-keying. Depending on the re-keying interval of
>the VPN gateway this may be the problem.
this does seems to happen when using the laptop with a better link quality

>Maybe same as above. In either case (if it's rekeying or not) I would
>think that these two problem are in fact the same.
Indeed, that was just to put in evidence that the vpn part was causing
the problem.

>Have you tried to run NetworkManager on the console with the --no-daemon
>option (this time I got it right :-) ) to see if there is any output
>before it hangs? Can you still login via SSH from outside the machine
>(that worked for me for a couple of hangs caused by the applet which
>have been solved) and kill NM/applet?
>	Tim
Will try with the nodeamon switch. I won't have the means to try to log
by ssh, however I'll test some scripts to check after a freeze whether
just X locked or the whole system.

I will keep you people informed.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]