Re: nm freezes system with nm-vpnc

Ferréol de Soras wrote:
> hi,
> I use vpnc to connect to my university's wifi network.

Versions of vpnc, NetworkManager and distro?

> *Not using networkmanager at all,  (iwconfig/dhclient/vpnc by hand)
> after a variable amount of time, (10 min, 1h, 3h, 6h...)  the link just
> hangs, ie no packet can go through the tunnel. Running commands

vpnc does not support re-keying. Depending on the re-keying interval of
the VPN gateway this may be the problem.

> *When just using  nework-manager to connect to the right SSID and get
> DHCP,  but running vpnc through the command line, it just works the
> same, ie connection hangs, but system doesn't.

Maybe same as above. In either case (if it's rekeying or not) I would
think that these two problem are in fact the same.

> *When using the vpnc-applet from network manager, when the vpn becomes
> unavaible, it hangs totally the system.

Have you tried to run NetworkManager on the console with the --no-daemon
option (this time I got it right :-) ) to see if there is any output
before it hangs? Can you still login via SSH from outside the machine
(that worked for me for a couple of hangs caused by the applet which
have been solved) and kill NM/applet?


    Tim Niemueller <tim niemueller de>
 Imagination is more important than knowledge. (Albert Einstein)

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]