nautilus does not start anymore after trying to connect to smb


My nautilus does not start anymore and I can't figure out why. 

Thats what I did: 

I tried to connect to a smb share on a windows pc which hang forever in
the connection dialog and also stalled any other nautilus operations,
e.g. clicking on desktop icons... 
After several retries with killing nautilus and restarting I gave up on
connecting to the smb share and logged out. 

The log out of gnome also hang forever and I therefore killed it with

After a new log in nautilus did not come up again :-(

Therefore I tried to start nautilus in the console.
But nautilus -c hangs forever after printing: 

running nautilus_self_check_search_uri 
running nautilus_self_check_file_utilities 
running nautilus_self_check_file_operations 
running nautilus_self_check_directory 

and the last few lines of an strace of the hanging nautilus shows: 

rt_sigsuspend([] <unfinished ...> 
--- SIGRTMIN (Unknown signal 32) @ 0 (0) --- 
<... rt_sigsuspend resumed> ) = -1 EINTR (Interrupted system call) 
sigreturn() = ? (mask now [RTMIN]) 
rt_sigprocmask(SIG_SETMASK, NULL, [RTMIN], Cool = 0 
rt_sigsuspend([] <unfinished ...> 

Any ideas how to recover?? 
Running bonobo-slay did not solve it. 

Thanks a lot, Fabian

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]